GNU/Linux packages

Started by rubdos
8be85caac78e76deced9182a23b67687?s=156&d=mm

rubdos

Hi,

I just made spec files for thebounty and the blender plugin, and uploaded them to copr.

I also made Debian, Ubuntu and openSUSE packages on OBS.

If someone's interested, you can install the Fedora (>=23) and CentOS 7 packages:

Fedora

dnf copr enable rubdos/TheBounty                                                
dnf install thebounty thebounty-blender

CentOS

wget -O /etc/yum.repos.d/ https://copr.fedorainfracloud.org/coprs/rubdos/TheBounty/repo/epel-7/rubdos-TheBounty-epel-7.repo
yum install epel-release # for python3
yum install thebounty

This soon will be This is now listed on our official downloads page.

Current version is 0.1.6.rc4, and I'm going to make it update automagically by tracking a branch in the git repo.

CentOS 7 sadly does not have Blender in its repo's and so thebounty-blender is not available there.

Debian Jessie (8) and Linux Mint DE 2

echo 'deb http://download.opensuse.org/repositories/home:/rubdos:/thebounty/Debian_8.0/ /' >> /etc/apt/sources.list.d/thebounty.list
apt-get update
apt-get install thebounty thebounty-blender

Ubuntu 16.04 (and Linux Mint 18)

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/rubdos:/thebounty/xUbuntu_16.04/ /' >> /etc/apt/sources.list.d/thebounty.list"
sudo apt-get update
sudo apt-get install thebounty thebounty-blender

Ubuntu 14.04 (and Linux Mint 17)

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/rubdos:/thebounty/xUbuntu_14.04/ /' >> /etc/apt/sources.list.d/thebounty.list"
sudo apt-get update
sudo apt-get install thebounty thebounty-blender

I'm still working to get Ubuntu 14.04 done via OBS, there's some trouble because 'universe' isn't available for it right now. Theeere we go. If they don't work, leave a message! :)

openSUSE (13.2, 42.1 and 42.2)

One click installs here

Yours,

Ruben

8be85caac78e76deced9182a23b67687?s=156&d=mm

rubdos

Update: packages for Ubuntu 16.04, Debian 8, Linux Mint 18 and 17, openSUSE 13.2, 42.1, 42.2 are available now. Please report back whether they work or not, and what needs to be improved.

8be85caac78e76deced9182a23b67687?s=156&d=mm

rubdos

Ubuntu 14.04/Mint 17 packages added; they were quite crappy to implement though, so let me know whether they work, if someone uses them… :)